


Hello, Reaperfriend! Alejandro here. 

I love REAPER with all my heart. I have been using it for over 12 
years and even though I've tried many other DAWs, I always come 
back to REAPER for the same reason, no other DAW is this flexible 
and powerful.   

Being so flexible isn't always good, though. It means options 
and tons of it. Which is why most people get overwhelmed when 
trying out REAPER for the first time. It almost feels like you are 
trying to drive a spaceship sometimes. At least that's how I felt! 

In my early REAPER days, I kept encountering stuff that frustrated 
me. But everything changed when I discovered that a lot about 
REAPER can be customized for your own taste and that's 
honestly huge. Putting some time into customizing the perfect 
DAW is super worth it in the long-run.  

That's why I decided to create this eBook. I know how 
overwhelming setting REAPER up can be. And this guide will be 
exactly what I would have loved to know when I was starting out. 

And even if you have used REAPER for a while, I am sure you will 
find a thing or two in here that you may like! 

All made with love, 

Alejandro Hernandez 

👋 Intro



How to use this guide 
From this point on, I will drop a bunch of tweak suggestions 
divided by categories. There's not really a specific order you need 
to follow. Just find something that interests you and set it up~ 

– Though, I highly recommend exporting your current settings 
just for safety! 

I wanna emphasize that these are only suggestions. They are 
all heavily biased towards what I like and dislike. And it's totally 
fine if you skip any or most of these! 

I will however add a small priority tag at the top of each 
suggestion. Again, highly biased XD  

🧭  Navigation tips 
• If you are on PC, you can use the arrows (◀/▶) to go to next/

previous page. I separated most of the tips by pages so it’s all 
aligned and easy to skim through!  

• Feel free to use the table of contents to easily find something 
that interests you! 

• There’s also a “▲ Return to index" button at the bottom left of 
each tip, this will take you back to the table of contents.  

• I suggest getting a nice cup of coffee //or tea or water//, read 
this guide while REAPER is open, and change whatever you 
think would be helpful for you.  

Enjoy and happy tweaking! 🚀  



Table of content 
Intro  2

How to use this guide  ........................................................................3
Table of content  ................................................................................4

Backup & Safety 
Export & backup your whole REAPER  ...............................................7
Timestamped project backups  .........................................................9

Navigation & Interface 
Transport controls  ...........................................................................14
Zoom towards your mouse  ..............................................................15
Hand scrolling navigation  ................................................................16
Disable highlight edit cursor over last selected track  .....................17
Uncluttered grid lines  ......................................................................18
Stop zooming out too far  .................................................................19
Disable “ignore mouse on all faders”  ..............................................20
Theme Adjuster  ...............................................................................21
Theme recommendations  ...............................................................30
Customizing toolbars  ......................................................................33
Saving and recalling custom layouts  ...............................................35
MIDI Colormaps  ...............................................................................37

Projects & Files 
Cleaner project folders  ...................................................................40
Open new project on startup  ..........................................................43
Disable splash screen  .....................................................................44

Media Items 
Adjust multiple fades at once  .........................................................46
Stop/repeat playback at the end of project  ....................................47
Default item timebase  .....................................................................48



Disable automatic fadein/fadeout  ...................................................49
Disable tiny fade-in on playback start  ............................................50
Handy media icons  ..........................................................................51

Recording & Optimization 
Disable Recording Prompt  ..............................................................54
Fastest way to record  ......................................................................55
Auto arming tracks  ..........................................................................57
Cleaner recorded filenames  ............................................................58
Show takes instead of lanes  ...........................................................59
Discard incomplete takes  ................................................................60
Preserve PDC on recorded items  ....................................................61
Smoother waveforms when recording  ............................................63

🛠  Latency issues? Try these!  ........................................................64

🔥  CPU Issues? Try these:  .............................................................66

Further optimize REAPER with these:  .............................................70

MIDI 
Disable Loop Item Source  ...............................................................73
One MIDI editor per project or track  ...............................................74
Input MIDI notes in one click  ...........................................................75
Remove MIDI note velocity handle  ..................................................76
Color by pitch and show note name  ................................................77

The end  78

❤  Support 79

5



CHAPTER 1 

Backup & Safety 



⬤ M U S T Backup & Safety

Export & backup your whole REAPER 
Before you set up anything, I highly recommend exporting your 
current REAPER settings. Just in case you want to revert back to 
your original setup.  

Luckily, REAPER makes exporting and importing every setting 
super simple to do! This is helpful for when you are maybe 
moving to another computer, sharing specific settings to friends, 
or just back-up in case your computer breaks!  

Setup: 

1. Go to Preferences > General > Select "Export 
Configuration"  

2. A checklist will appear. If you check all, this will export 
eeeverything. Giving you an exact replica of your current 
REAPER when you import this file into another REAPER. 

▲ Return to index 7



⬤ M U S T Backup & Safety

After it’s done exporting, you should end up with a 
single .ReaperConfigZip file. You can store this file somewhere 
safe.  

On top of backing up that file locally, I highly recommend 
uploading it to the cloud as well! 

▲ Return to index 8



⬤ B AC K U P  F O L D E R Backup & Safety

Timestamped project backups 
Okay, this is honestly a LIFESAVING feature 👏   If you don’t ever 
want to lose important progress in your projects, check this out! 

You can set up REAPER to do automatic time-stamped backups 
of your projects. This is especially useful when you want to go 
"back in time" on your projects.  

Example: 

Let's say you were mixing a session and you deleted a track long 
ago and forgot about it. With this method, you can just go back to 
the time where you had this track, open it and get the track back. 

Or maybe the mix isn't feeling quite right and you wanna go back 
to the mix you had yesterday. Also possible! 

This gives me peace of mind when I am deleting or doing big 
changes. If anything, I can always go back! 

There's three ways you can set this up. 

1. All backups inside one global folder. (My preferred method) 

2. Backups inside a subfolder of the project. 

3. All backups inside a “.rpp-bak" file next to the project.  

▲ Return to index 9



⬤ B AC K U P  F O L D E R Backup & Safety

Method 1 – All backups inside one global folder 

I personally prefer setting up one big folder for all backup 
sessions. With everything in one folder, it's easy to clean-up 
every now and save some space.  

Setup: 

1. Go to Preferences > Project 

2. In the project saving section, check “Save to timestamped 
file in additional directory” and set a path for your backups.  

3. You are free to choose how often it saves a new backup. I like 
to keep it at 5 minutes.  

4. Done! From now on, all time-stamped backups will show up in 
the folder you set.

▲ Return to index 10



⬤ B AC K U P  F O L D E R Backup & Safety

Method 2 – Backups inside a subfolder of the project 

This way is also nice! You can keep your backups in its own folder 
inside the project folder.  

The way you do it is to follow the same steps as above, but 
instead of choosing a folder path, just type "Backups". This will 
create a folder inside the project folder.  

⚠  One thing, though. You have to make sure that your projects 
are saved in its own folder. So when you click on "New Project". 
Make sure to tick this box at the bottom that says "Create 
subdirectory for project". (You can create the folder manually as 
well!)

▲ Return to index 11



⬤ B AC K U P  F O L D E R Backup & Safety

Method 3 – .RPP-Bak file versions 

By default, when saving sessions, REAPER renames the old 
project to ".rpp-bak". We can enable this file to store 
timestamped versions of every time we save our projects.  

To do that, go to Preferences > Project > and check these 
boxes: 

This will embed all time stamped backups into one single 
file .rpp-bak file. This is the file that will appear next to your 
main session file and when you double click on it, you will see a 
list of timestamps that you can choose from. 

⚠  Note: this file can get a bit large cause it saves a new version 
every time you save. It’s not like the previous two methods where 
it autosaves a separate file every x minutes. That's why I don't 
really use this and use method 1 instead.  

▲ Return to index 12



 

CHAPTER 2 

Navigation & 
Interface 



⬤ N I T P I C K Navigation & Interface

Transport controls 
You can move the transport bar anywhere in REAPER. By default 
it's positioned at the bottom which isn't very visible to me. I like to 
place this at the very top. 

Setup: 

1. Right click the transport bar and select Docked Transport 
Position > Top of Main Window 

2. I like to keep it centered. Right click again the transport bar 
and select Center transport controls

▲ Return to index 14

Before After



⬤ U S E F U L Navigation & Interface

Zoom towards your mouse 
By default, you have to click and place the edit cursor wherever 
you wanna zoom towards, and I think that's just unnecessary 
extra work. 

I find it better to zoom towards my mouse cursor. It feels way 
more natural this way! 

Setup: 

1. Go to Preferences > Editing Behavior  

2. In Horizontal Zoom Center, select Mouse Cursor   

▲ Return to index 15



⬤ U S E F U L Navigation & Interface

Hand scrolling navigation 
Once I discovered that you could hand scroll your way around 
REAPER, I couldn't go back. This is my favorite way to navigate 
around the Arrange View. I like to set this to my middle mouse 
click.   

Setup: 

1. Go to Preferences > Mouse Modifiers  

2. From the dropdown list, select Arrange View / Middle Drag 

3. Double click the default action and select “Hand scroll” 

4. Done! Now you should be able to click and drag with your 
mouse-wheel to navigate around the Arrange View. 

▲ Return to index 16
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Disable highlight edit cursor over 
last selected track 
I am probably one of the few people that really dislike this lol. But 
idk, I find it distracting and redundant? – I mean, the track is 
highlighted and the edit cursor is pretty visible. 

Setup: 

1. Go to Preferences > Appearances 

2. Uncheck “Highlight Edit Cursor”

▲ Return to index 17
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Uncluttered grid lines 
It has always bothered how projects look when zooming out 
because of how cluttered the grid lines look like.  

I prefer to set a bigger minimum grid line spacing. This way 
when I zoom in, it will reveal more grid lines and the opposite will 
happen when I zoom out.  

Setup: 

1. Right click the grid icon in your top left toolbar above 
tracks.  

2. Play around with the minimum of pixels. I like to set it at 46. 

▲ Return to index 18

Before After



⬤ N I T P I C K Navigation & Interface

Stop zooming out too far  
You can set a project length limit so it prevents you from 
zooming out past that limit.  

I like to set this up once I’ve got a good idea of the project 
boundaries. That way when I zoom out, it will only show me the 
full project.  

Setup: 

1. Go to File > Project Settings… 

2. Check “Limit project length, stop recording/playback at” 
and enter a time. [hours:minutes:seconds:milliseconds] 

3. You can save this as a project default if you want, altho I 
prefer to set it just per-project. 

▲ Return to index 19
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Disable “ignore mouse on all faders” 
I loooove using my mouse-wheel to control faders, I think it's the 
closest feel to an actual fader I can get while mixing. But I 
understand why this is disabled by default since it may cause you 
to accidentally adjust a fader when you meant to scroll around.  

I've had this disabled for many years with no issues. But I gotta 
admit that at first, I kept accidentally adjusting faders. But you 
start to grow muscle memory of avoiding the fader zone when 
you wanna scroll.  

Setup: 

1. Go to Preferences > Editing Behavior > Mouse 

2. Uncheck “Ignore mouse-wheel” 

I also suggest checking "Ignore mouse wheel on transport edit 
fields”. This way you don't accidentally change BPM or play-rate. 

Optionally, you can set it so it ignores mouse-wheel just on the 
track panel by checking "Ignore mouse-wheel on track panel 
faders". This way it will only work on the mixer. 

▲ Return to index 20



T H E M E  A D J U S T E R Navigation & Interface

Theme Adjuster 
One of the main features of REAPER v6 was the addition of the 
theme adjuster. A script that allows you to tweak most of the UI 
elements and how they behave.  

To bring this up, go to the Actions window and search for “Script: 
Default_6.0_theme_adjuster.lua” 

Feel free to spend some time here tweaking stuff to your liking!  

If you enable the question mark icon at the top left, helpful hints 
about whatever you have your mouse on will appear. Everything is 
pretty intuitive and changes are in real-time.  

▲ Return to index 21



T H E M E  A D J U S T E R Navigation & Interface

Theme adjuster tips 
There's a couple of suggestions I have that you can consider. So I 
will share my settings and go over what I changed and why. 

Track control panel 

👆 My track control panel settings. See pages below for more info 
about the changes. 

▲ Return to index 22



T H E M E  A D J U S T E R Navigation & Interface

Full controls 
You may notice that tracks have missing elements like input, 
values, monitor and record mode. On top of that, when the mixer 
is open, the pan and routing buttons are gone. 

Personally, I prefer to consistently have all controls in my tracks. 
So I just remove all the "HIDE" from the table. Except for "record 
mode" – I never really use that and in the case I need it, I just right 
click the record arm button. So that stays hidden. 

▲ Return to index 23

Before After



T H E M E  A D J U S T E R Navigation & Interface

Faders, meter & input size 
I love faders on the TCP, so I set the volume size to about 100. A 
lot of the mixing I do it from the track panel, that's just how I got 
used to it.  

Meter size is about 20 so it shows the values. Pretty helpful.  

Input size can go to 40, I don't usually need it that wide. 

▲ Return to index 24
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Align controls 
I like to set this to "Extend name". I think this is the most elegant 
way yet to keep the faders in the TCP always aligned. Since I do a 
lot of mixing in my TCP, I find this crucial to my workflow.   

Folder indent 
I think 1/2 is good. Since I do a lot of subfolders, I'd often run out 
of space if I had it set to 1. If you don't use a lot of subfolders, 1 is 
fine! 

▲ Return to index 25

Before After

Before After



T H E M E  A D J U S T E R Navigation & Interface

Mixer control panel 

👆 A lot of the controls in here I just left untouched. Couple of 
things, though:

▲ Return to index 26



T H E M E  A D J U S T E R Navigation & Interface

Do meter expansion 
I like to disable this completely. This expands the track meters 
when you have a track with multiple outs (like a drum sampler) 
resulting in a super wide track. I don't find that useful and it just 
looks weird. So I disable it.  

Borders 
I think borders around folders are pretty helpful! Combined with 
aligned controls and a folder indent of 1/4 is pretty good visual 
cue of your folders and subfolders.  

▲ Return to index 27

Before After

Before After



T H E M E  A D J U S T E R Navigation & Interface

Show multiple-row mixer when size permits 
I'd disable this. I find this layout super messy to follow.   

Clickable icons for folder tracks 
Okay, this option isn't really in the theme adjuster but I think it's 
veeery helpful. 

Just search in the Action window for “Mixer: Clickable icon for 
folder tracks to show/hide children” and enable it. 

▲ Return to index 28

Before After

Before After



T H E M E  A D J U S T E R Navigation & Interface

Global Settings 

I love this page! – In here you can adjust stuff like brightness, 
saturation, gamma and even tint of REAPER in real-time. Every 
screen and taste is different.  

Personally, I like just a little bit more of contrast and brightness 
and a touch of saturation. Feel free to experiment with this until 
you find something you like!

▲ Return to index 29
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Theme recommendations 
Since we are in the customizing mood 👨🎨 , you may wanna try out 
some themes! There’s bunch out there but here are my favorites. 

👇  Click on the theme name to download 

Smooth 6 

Echolot (FTC Mod)

▲ Return to index 30

Smooth 6 has been my go-to theme for a while. It’s so beautiful!

https://forum.cockos.com/showthread.php?t=228983
https://forums.cockos.com/showthread.php?p=2546076
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Magic Clover 

Mammoth 

Peace

▲ Return to index 31

https://stash.reaper.fm/theme/2761/Magic_Clover_Dark.ReaperThemeZip
https://forum.cockos.com/showthread.php?t=246466
https://forum.cockos.com/showthread.php?t=265339
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iLogic 3.90 

Those were my favorites!  
You can find more themes here. 

▲ Return to index 32

(To get iLogic theme you first need to make a donation to the creator)

https://forum.cockos.com/showthread.php?t=214879
https://forum.cockos.com/showthread.php?t=214879
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Customizing toolbars 
One of the things that made me fall in love with REAPER is how 
you can pretty much set different toolbars filled with your favorite 
actions and position them strategically. 

Adding / removing actions to toolbars 
I often use the freeze and unfreeze actions. It would be a great 
idea to set them up on my main toolbar.  

To do that, just right click any empty space of the toolbar and 
select “Customize toolbar”. 

In this menu you can add and remove any action and even set 
icons for them. 

▲ Return to index 33



⬤ U S E F U L Navigation & Interface

In this case I will press “Add…” and find the actions for freeze / 
unfreeze and select them. They will now get added to the list.  

You can add a separator by right clicking the list and selecting 
“Insert separator” 

And there you go! You can spend some time here and maybe 
delete some actions you don’t use much just so it looks cleaner. 

👇  In the next tip I will show you how to set up some cool layouts 
using this knowledge!  

▲ Return to index 34



⬤ U S E F U L Navigation & Interface

Saving and recalling custom layouts 
You may wonder how people get all these cool layouts in REAPER:

▲ Return to index 35

Selected 
track 
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3 top toolbars
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Video 
Window
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What makes REAPER so powerful is that you can actually switch 
between all of these by just using shortcuts. And while it looks 
complicated, it’s actually pretty easy to set up!  

It’s all a combination of understanding how to customize 
toolbars, how docking works, and how to save and recall them 
using screensets.  

I filmed this quick video to demonstrate how all of that works and 
also give you some ideas on how to use it.  

📹  Watch:  How to set up custom layouts + 3 layout ideas! 

▲ Return to index 36

MIDI Editor

https://youtu.be/5gtaoqFnzF0


⬤ N I T P I C K Projects & Files

MIDI Colormaps 
If you aren’t too happy about how the MIDI notes look in REAPER, 
the good news is that there’s a bunch of appearances you can try.  

Super easy to install as well! 

Setup: 

1. Go to Preferences > MIDI Editor. And in “Default colormap”, 
load a colormap file.  

2. I prepared a zip file with some of my favorite colormaps! 

• ⬇  Download my collection of colormaps. 

• 👀  Click here to see a preview of how they all look. 

▲ Return to index 37

https://reapertips-s3.s3.us-east-2.amazonaws.com/downloads/RT-MIDI-Colormaps.zip
https://www.instagram.com/p/CDWkOomF7dB/
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3. Alternatively, you can visit the REAPER stash to find more 
colormaps to try.  

• Colormaps in the REAPER Stash 

Create your own 
If you would like to create your own colormap, check out this 
super intuitive and interactive tool someone made.  

Reaper MIDI Colormap Tool - Demo Video

▲ Return to index 38

https://stash.reaper.fm/browse.php?q=colormap&x=0&y=0
https://youtu.be/8863xvMdcWM
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⬤ M U S T Projects & Files

Cleaner project folders 
REAPER puts all audio, reapeak files and projects next to each 
other and that's honestly super messy, in my opinion. Let's start 
by setting up a dedicated audio folder for each project. 

Setup: 

1. Go to File > Project Settings > Media 

2. Type 'Audio' in the first path. 

3. Lastly, click 'Save as default project settings', this way 
future projects will have a dedicated audio folder for each 
project. 

▲ Return to index 40

Before After
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Set a path for reapeaks 
Lastly, let's take care of reapeaks. These are tiny image files that 
REAPER generates to draw media item's waveforms.  

There really is no need to have these in your project folders. I 
prefer having one dedicated folder outside projects in my 
computer for it. 

Setup: 

1. Go to Preferences > Paths 

2. Enable 'Store all peaks in alternate path' 

3. Click browse, and make a folder somewhere in your 
computer, you can call it "Reapeaks". Set this folder as your 
reapeak path. 

▲ Return to index 41
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4. Done! All of your future projects should now look like this. 

How to fix old projects? 
Jon from The REAPER Blog made an awesome video tackling 
exactly this. 

• Check it out! 

▲ Return to index 42

https://youtu.be/EPQ5bZXoXlQ
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Open new project on startup 
By default, REAPER opens the last active project, that means that 
every time you open reaper, you have to wait for it to load your 
last session.  

I much prefer REAPER to just open a new blank project so it loads 
way quicker and I can get started with whatever I need at the 
moment.  

Setup: 

1. Go to Preferences > General 

2. Find “Open projects on startups” and select “New project” 

3. You can also set it to “prompt” if you prefer. This will show 
you a list of your most recent projects which is pretty cool too!

▲ Return to index 43
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Disable splash screen 
This is a little silly but you can make REAPER start up 1-2 seconds 
faster if you disable the splash screen animation that appears 
every time you open up REAPER 😆  

Setup: 

1. Go to Preferences > General 

2. Disable “Show splash screen on startup”

▲ Return to index 44
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⬤ M U S T Media Items

Adjust multiple fades at once 
It is so weird to me that by default, REAPER won’t allow you to 
edit multiple fades when selecting multiple items. Luckily, it’s an 
easy fix.   

Setup: 

1. Go to Preferences > Mouse Modifiers 

2. Select context: Media Item fade/autocrossfade | Left drag 

3. Double click default action and select Move Fade > “Relative 
edge edit”  

4. Now you should be able to edit multiple fades at once! 

▲ Return to index 46
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Stop/repeat playback at the end of 
project 
I like to disable this. When I play with a metronome, I get annoyed 
that the project would stop at the end and return to the 
beginning. Disabling this makes sure it keeps going forever. I find 
it makes arranging and playing a little more flexible.  

Setup: 

1. Go to Preferences > Audio > Playback 

2. Disable “Stop/repeat playback at end of project"

▲ Return to index 47

✅
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Default item timebase 
A lot of people get confused when they import an audio file into 
REAPER and change BPM, all of their files get stretched and 
pitched.  

For more context check out this example case. 

I like to set the default timebase to Time instead of Beats so that 
case above doesn’t happen.   

Setup: 

1. Go to File > Project Settings… 

2. Where it says “Timebase for items/envelopes/markers” select 
“Time”

▲ Return to index 48

❌

https://youtu.be/eus1hMD_eUo?t=94


⬤ M U S T Media Items

Disable automatic fadein/fadeout 
Alright, this is honestly a very strange default. Every time you 
make a split in REAPER, it creates an automatic fade in and out 
that looks like this: 

The intention with this is that it saves you from pops and clicks. 
And while it works, it's just problematic for one big reason. 

It's way too large! 

For example, if you split a snare right at the start, it will 
completely remove some of the attack and it's a very audible dip.  

To solve this, 

1. Go to Preferences > Media Item Defaults  

2. Set automatic fades to 1 ms instead of 10 ms 

Now, personally I like to just disable this cause I wanna have full 
control of it. But if you wanna keep it, at least keep it to 1 
millisecond. That should be enough to prevent a pop.

▲ Return to index 49
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Disable tiny fade-in on playback 
start 
This is a similar situation to the previous tip, but this time is on 
playback. By default, you hear a tiny fade in when you press play. 
This fade-in is enough to misjudge a kick or a snare because it 
will remove some of the attack.  

Setup: 

1. Go to Preferences > Audio  

2. Uncheck “Tiny fade out on playback start”

▲ Return to index 50
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Handy media icons 
One of the coolest thing about REAPER is all the processing and 
tweaking you can do to individual items. You can insert effects, 
automate volume/pitch/pan, mute, add comments and more! 

You can make your items have all these buttons:   

Setup: 

1. Go to Preferences > Appearance > Media 

2. In here, you can check the boxes for "Not muted", "No FX", 
"No active envelopes" or anything else that you'd like to see 
like notes, lock or item properties. 

▲ Return to index 51



⬤ U S E F U L Media Items

You can also enable a volume knob!  
In the same location as before, just check the box that says 
"Volume knob".  

I would also get rid of the handle since we now have this handy 
knob. At the bottom of the screen where it says “Item Volume 
Handle”, select "No handle”. 

Disable resampled media icon 
Another thing you may wanna uncheck is "Item properties only 
if resampled media". I don't think it's necessary to have that icon 
when items are resampled.

▲ Return to index 52

Btw, this happens when you import a file that doesn’t match your session’s 
sample rate and REAPER has to resample it. The little icon is just letting you 
know it’s happening. It’s okay to ignore it~
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⬤ U S E F U L Recording & Optimization

Disable Recording Prompt 
I find this prompt really annoying! It just gets in the way every 
time you stop recording and gives you a bunch of options.  

Some people like it because they can choose to delete the file 
and save space. But I prefer to set a shortcut for that using the 
action "Transport: Stop (DELETE all recorded media)". This 
makes recording way quicker and straightforward. 

Let me show you how to get rid of that prompt: 

Setup: 

1. Go to Preferences > Recording 

2. Uncheck “Prompt to save/delete/rename new files”

▲ Return to index 54
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Fastest way to record 

By default, you have to press Ctrl + R to start recording. This is 
two keys, which is honestly a lot for an action that you will use 
often.  

I prefer to change the Record shortcut to a single key 
shortcut like “E”. 

I also find time consuming all the constant stopping with space 
bar, then having to delete or keep your takes.  

What I like to do instead is setting a single key shortcut to the 
action called “Stop (Delete all recorded media)”. That way I 
could press this key to stop the recording and delete the take. 

I only press this key when I am 100% sure that I messed up and I 
don’t wanna keep that take. And in the case I want to keep the 
take, I press space. 

▲ Return to index 55
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In short,  
🔴  I press “E” to start recording. 

✅ If I want to keep the take, I press “Space” 

❌  If I mess up while recording, I press “Q” to trigger the action 
“Stop (Delete all recorded media)” 

Setup: 

Go to Actions menu and set single key shortcuts to the following 
actions:  

• “Transport: Record” – I set “E”. 

• “Transport: Stop (DELETE all recorded media)” – I set “Q”.

▲ Return to index 56
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Auto arming tracks 
You can make REAPER auto-arm your tracks when they are 
selected. Music producers find this helpful because it allows 
them to quickly hear and record different instruments without 
having to turn tracks off/on. 

Setup: 

1. Right click the recording button on a track and select 
“Automatic record-arm when track is selected” 

2. If you want this to be the default of all new tracks in the 
future, go to Preferences > Track/Sends Defaults and where 
it says “Record config”, enable “Automatic record-arm 
when track is selected”

▲ Return to index 57



⬤ N I T P I C K Recording & Optimization

Cleaner recorded filenames 
The way REAPER names recorded files is veeeery long and 
detailed. It's usually something like this: 

“03-GtrL190703_0840.wav”  

That's track number, track name, year, month, day, hour and 
minutes. Most of this data is already being stored in your .wav 
file, so in many instances, there really isn't a need to include that 
in the filename.  

The way I like to name these is just using the track name and the 
recording pass number.  

Setup: 

1. Go to Preferences > Recording 

2. In filename format, type: "$track- $recpass00" and save. 

▲ Return to index 58

Before After



⬤ U S E F U L Recording & Optimization

Show takes instead of lanes 
You may have noticed that if you record on top of another item, 
REAPER shows you all the different takes in multiple lanes.  

This is useful but not always ideal. I prefer to set the default to 
show me takes instead of lanes.   

Setup: 

To set this up, go to top menu Options and uncheck "Show all 
takes (when room)” 

To save this as default, go to top menu File > Project Settings 
and click "Save as default project settings"

▲ Return to index 59
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Discard incomplete takes 
If you do loop recording, I highly suggest enabling this. It will 
basically discard whatever take is not completed. That means you 
won't have takes that are literally guitar noise as you are reaching 
for the stop button.   

Setup: 

1. Go to Preferences > Audio > Loop Recording 

2. Check the first box, and set the threshold for complete take to 
90%. 

▲ Return to index 60
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Preserve PDC on recorded items 
Some plugins in your track’s FX chain may introduce some PDC 
(Plug-in Delay Compensation). You can see the PDC amount, if 
there’s any, in top menu View > Track Manager.  

^ In this case, I have a guitar track with an amp sim and a multi-
band compressor. I checked the track manager and I can see that 
there’s 886 samples of PDC.  

Converting those samples to milliseconds would be 886/44.1 = 
about 20 milliseconds. (That’s samples/samplerate)  

That means what you are hearing has about 20 milliseconds of 
latency. It’s pretty small and unnoticeable when playing.  

However, by default, REAPER doesn’t preserve those milliseconds 
of delay in the recording. So technically what you are hearing 
when monitoring isn’t going to be exactly what ends up in the 
recording time-wise.  

So… 
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✏  In easier words,  
If you want what you heard out of your speakers while you were 
recording to be what's played back, then enable this.  

If you want what you physically played (without the PDC), to be 
what's played back, keep this off. The former is what your ears 
heard, the latter/default is what your fingers did. 

Some people will prefer one over the other, but I feel like that's an 
important one for every user to know.  

Setup: 

1. Go to Preferences > Track/Send Defaults  

2. Click on Record config and select “Preserve PDC on 
Recorded Items.”
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Smoother waveforms when 
recording 
You may have noticed that when REAPER is recording, waveforms 
are drawn very slowly. And it's because the default refresh rate of 
this is only 3 Hz. We can crank this to 30 Hz and make it look 
waaay smoother. 

This is especially cool if you film videos like this! 

Setup: 

1. Go to Preferences > Recording 

2. Where it says "Show preview ...update frequency" set it to 
30 Hz. 

Note: So far I haven't noticed any performance hiccups when 
setting this up, even when I have it at 60Hz. 

▲ Return to index 63
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🛠 Latency issues? Try these! 

Lower your block size 
When your buffer size is high, you give REAPER more time to 
process things, this however introduces latency. The key to 
latency-free tracking is to have the lowest buffer size.  

In Preferences > Audio > Device, check "request block size" 
and go as small as you can go. Start with 96. If you hear cracks 
and pops, try 128 or 256.  

The rule of thumb for block size is:  

• Set to high buffer size if you are mixing. 

• Set to low buffer size if you are tracking. 

Sidenote: if you have Reapack installed, there's a series of 
scripts to quickly change block size. I love having this as 
keyboard shortcuts for quick switch. Check it out here. 

▲ Return to index 64
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Bypass high-latency plugins 
Some plugins like multi-band compressors, limiters and 
saturators introduce a great amount of latency to your sessions. 

You can check which plugins are introducing latency by going into  
the top menu View > Track Manager. 

In here you will find a column called "PDC" – This means "Plug-in 
Delay Compensation" and the  number is the amount of samples 
of delay.  

Whenever you spot a track using PDC, you can go to the track FX 
and bypass the plugin adding the latency. Or you can click the 
PDC number in the Track Manager to bypass the whole track.  

Alternatively, there's a super convenient script called "Toggle 
bypass all project FX with latency (PDC) higher than 128 
samples”. This script is available through Reapack. I use this all 
the time!

▲ Return to index 65
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🔥 CPU Issues? Try these: 

Increase your block size 
Once again, the rule of thumb for block size is:  

• Set to high buffer size if you are mixing. 

• Set to low buffer size if you are tracking. 

In this case we want it high, so go to Preferences > Audio > 
Device, check "request block size" and type 1024. If still 
struggling, go 2048.  

▲ Return to index 66
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Track freeze 
This renders the tracks and removes all the FX. Super useful for 
when you have tracks with lots of effects like guitars or sound 
effects.  

To do this: right click track(s) > Render/Freeze Track > Freeze 
Tracks 

And if you ever wanna go back, you can go to the same location 
and unfreeze it. 

I highly recommend setting up shortcuts to these actions or add 
them to a toolbar if you find yourself using this a lot: 

• “Track: Freeze to stereo (render pre-fader, save/remove 
items and online FX)" 

• "Track: Unfreeze tracks (restore previously saved items 
and FX)” 

▲ Return to index 67
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Subproject 
If you don't know about sub-projects, I highly suggest watching 
this awesome video by Akash Thakkar about how useful these 
are!  

I use this a lot for when I am going crazy with sound design in my 
sessions. I just grab all of my layers and move them into a 
subproject. Or maybe all my drums. Or any other group of tracks!  

▲ Return to index 68
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Apply FX to items 
You can right click any item and select "Apply track/take FX to 
items as new take".  

This is perfect for when you are having a small section with tons 
of plugins and you just wanna render that part.  

This isn't destructive either, you will still have the original as a 
take!  

▲ Return to index 69
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Further optimize REAPER with these: 
Media buffer size 
This is how long you give REAPER to get the audio from the hard-
drive and start playing it back. By default it's set to 1200ms/100% 
which is a little too much.  

1. Go to Preferences > Audio > Buffering  

2. Locate Media buffer size. Drop this to about 600ms/50% 
and you will notice a snappier response when you press play! 

You can also play around with setting a number of threads for 
audio processing as shown in this video by The REAPER Blog. 

However, I personally didn't notice much of an improvement so I 
just left it at auto-detect.   

▲ Return to index 70
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Set render block size 
By default, REAPER renders using whatever block size you have 
going in your session. This may make some plugins underperform 
in the rendered version. It's better to set this to 1024 samples, 
this way it has enough processing time for plugins to work 
properly. 

Setup: Preferences > Audio > Rendering > Set to 1024 
samples. 

▲ Return to index 71
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Disable Loop Item Source 
By default, when you drag the edge of an item, it will start looping 
instead of extending the item. Most people, including myself, find 
this odd and prefer to have always extend the item.   

Setup: 

1. Go to Preferences > Media Item Defaults 

2. Disable all these boxes (Loop source for...) 

3. Hit 'OK' and now you can extend MIDI items without worrying 
about loops.  

🚀 Note: I came up with a pretty cool to toggle this by double 
clicking the edge of the item. Check it out here! 

▲ Return to index 73
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One MIDI editor per project or track 
Normally, when you double click a MIDI item it opens up the MIDI 
editor. By default, REAPER will continue to open different MIDI 
editor windows for any other MIDI item you double click. This can 
get a little messy and confusing.  

I prefer to set a MIDI item per project instead of per media item.   

Setup: 

1. Go to Preferences > MIDI Editor  

2. Select "One MIDI editor per Project” 

Note: You can also try by track or leave it at media item. However 
you prefer! 

▲ Return to index 74
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Input MIDI notes in one click 
The way you have to insert notes in the MIDI editor in REAPER is 
by clicking and dragging a bit. This is a bit slow and troublesome 
especially when dealing with drums!  

Setup: 

1. Go to Preferences > Mouse Modifiers, Context: MIDI Piano 
Roll | Left Click 

2. Double click on default action. Select "Insert note > Just 
insert" 

3. Now you should be able to insert notes in the MIDI editor in 
just one click. 

💬  Now, you may now wonder “how do I unselect notes now?”. 
You can press shift + click anywhere in an empty field of the MIDI 
editor. 

▲ Return to index 75
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Remove MIDI note velocity handle 
You may have noticed MIDI Notes have a little horizontal line that 
you can drag to adjust the velocity. While this is handy, it's very 
easy to accidentally click.   

Setup: 

1. In the top menu go to View > Piano roll notes > Show 
velocity handle on notes 

🔥 Bonus tip: You can alt+click+drag up/down to change a 
note's velocity up and down. I way prefer doing this!

▲ Return to index 76
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Color by pitch and show note name 
You can customize the way you see MIDI notes further with these 
options.  

• To show the note name, go to View > Piano roll notes > Select 
“Show note names on notes”. Or press alt+0. 

•  To change color, go to View > Color notes by > and select 
your preferred way.  

I like to alternate between "by pitch" and "by velocity". And I do 
that by setting a shortcut to these two in the Actions window or 
placing them in the MIDI editor's toolbar. 

▲ Return to index 77



🤗  Thank you for reading my first eBook! Seriously, it means a 
lot. This is something I've been wanting to do for so long but was 
terrified. Nevertheless I put my heart and soul into it wishing you 
have a good experience 💙    

If you have any sort of feedback, I would love to hear it! I 
definitely would love to make more of these and this was such a 
huge learning experience for me.  

You can send me a DM on Instagram. Or email 
alejandro@reapertips.com 

Also if you think I missed something, let me know! I will keep 
adding things in here as I keep finding.  

💪  Special Thanks 
I want to give a special thanks to Jon Tidey from the REAPER 
Blog for the inspiration of creating this. He made a super amazing 
series of videos about this topic, I highly recommend checking 
out! 
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thank you reaper friend!!
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If you donated to get this, I wanna emphasize how much you are 
helping make my ambitious Reapertips projects like this happen. 

Even $1 helps a ton! And I am forever grateful <3 <3  

My next priority is building a Reapertips website. I am 
envisioning something like a big database of tips where you can 
easily find and discover cool reaper stuff! 

While I am designing and creating all the content myself, I still 
wanna pay someone fairly to help out with the programming 
side of things on top of all the monthly services fees. 

So ye, your support helps a ton! 

❤
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Here's a sneak peak of what’s coming! 
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